Welcome Guest! Log in

Topic-icon Question SVN Installation on Stambia 17.2.10

More
20 Nov 2014 09:52 #1 by norauto
SVN Installation on Stambia 17.2.10 was created by norauto
Hello,

I want to install SVN plugin on Stambia.
I use "Install New Software" in help menu.
I add " subclipse.tigris.org/update_1.10.x/ " location and I check all box.
The installation stops at error 56% and close 5-10mn later.

Do you get this problem also ? And what is the solution ?

Thanks
Attachments:

Please Log in or Create an account to join the conversation.

More
20 Nov 2014 14:51 - 20 Nov 2014 14:52 #2 by Thomas BLETON
Replied by Thomas BLETON on topic SVN Installation on Stambia 17.2.10
Hi,
You don't need to check all the components.
For most cases, checking the following items is enough :
Subclipse (Required) 1.10.6
Subversion Client Adapter (Required) 1.10.2
SVNKit Client Adapter (Not required) 1.8.9

Does it work better with only these items selected ?
Edit : retry on a fresh install, not on the one that is maybe corrupted.
Last edit: 20 Nov 2014 14:52 by Thomas BLETON.

Please Log in or Create an account to join the conversation.

More
20 Nov 2014 14:59 - 20 Nov 2014 15:02 #3 by Nicolas Verscheure
Replied by Nicolas Verscheure on topic SVN Installation on Stambia 17.2.10

norauto wrote: Hello,

I want to install SVN plugin on Stambia.
I use "Install New Software" in help menu.
I add " subclipse.tigris.org/update_1.10.x/ " location and I check all box.
The installation stops at error 56% and close 5-10mn later.

Do you get this problem also ? And what is the solution ?

Thanks


I don't know if it can help you :









If we keep the "Mylin" component, the install process failed all the time.
Attachments:
Last edit: 20 Nov 2014 15:02 by Nicolas Verscheure.

Please Log in or Create an account to join the conversation.

More
20 Nov 2014 17:15 - 20 Nov 2014 17:32 #4 by Nicolas Verscheure
Replied by Nicolas Verscheure on topic SVN Installation on Stambia 17.2.10
Once the installation is complete, the Designer will restart and ask you :



A best pratice is to uncheck this option. Another warning may appear :



To avoid this Warning at launch of the Designer, go to preferences and select the following option :

Attachments:
Last edit: 20 Nov 2014 17:32 by Nicolas Verscheure.

Please Log in or Create an account to join the conversation.

More
21 Nov 2014 15:30 #5 by norauto
Replied by norauto on topic SVN Installation on Stambia 17.2.10
Hello,

I try each proposition. I always get the error at 56%.
To close Stambia, I must kill Stambia process. I use option "-clean". (Stambia32.exe -clean) to launch Stambia again.

Even if SVN appear, I have not SVN client (see file)
Attachments:

Please Log in or Create an account to join the conversation.

More
21 Nov 2014 18:03 #6 by Nicolas Verscheure
Replied by Nicolas Verscheure on topic SVN Installation on Stambia 17.2.10
I've asked my infrastructure administrator : the SVN plugin has been installed on an internal server. Indeed, we experienced troubles to install the plugin through our proxy.

So, can you try to install the plugin in an environment that requires no proxy ?
Otherwise, can you ask your infrastructure department to install the SVN plugin archive on an internal server ? Or try it on localhost with an Apache server :)

Please Log in or Create an account to join the conversation.

More
16 Feb 2015 10:30 - 16 Feb 2015 10:33 #7 by Thomas BLETON
Replied by Thomas BLETON on topic SVN Installation on Stambia 17.2.10
Hi,

The support & R&D teams had some tests and we figured the following install procedure.
- select those 3 plugins : Subclipse (Required), Subversion Client Adapter (Required), SVNKit Client Adapter (Not required)

- on a 32 bits JVM, the installation process may block (at 56%). This is an issue we are currently investigating.
- workaround: just kill the Stambia process (this is harmless: the installation is in fact finished...).

- there is another issue related to a bug in SVNkit: issues.tmatesoft.com/issue/SVNKIT-555
- the issue is that SVNKit is not available in SVN Preferences in the SVN interface list.
- workaround: add the following line to stambia32.ini and relaunch stambia :
-Dorg.osgi.framework.executionenvironment=OSGi/Minimum-1.0,OSGi/Minimum-1.1,OSGi/Minimum-1.2,JRE-1.1,J2SE-1.2,J2SE-1.3,J2SE-1.4,J2SE-1.5,JavaSE-1.6,JavaSE-1.7,J2SE-1.6
Last edit: 16 Feb 2015 10:33 by Thomas BLETON.

Please Log in or Create an account to join the conversation.