Welcome Guest! Log in

Topic-icon Question Exception : java.rmi.UnmarshalException: Error unmarshaling return header

More
07 Jul 2016 12:12 #1 by Josserand BRINON
Hi,

Every time we want to execute a process in our Development runtime, we encounter this error message:
Exception : java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is: 
	java.net.SocketTimeoutException: Read timed out

On our Validation and Production runtimes, it works.
So far, we execute sub-process after sub-process (to reproduce the whole process), but we cannot continue on this way.

On our 3 servers, available RAM is low, but it seems to be enough on the Validation and Production servers.
Is that could be the reason of our issue?
What other reasons coult it be?

Thanks.

Please Log in or Create an account to join the conversation.

More
07 Jul 2016 18:01 #2 by Cyril Dussud
Hi,

This error might be due to the response time of the Runtime more than a RAM problem.
Can you give a little more details about the problem ?

1. What is the value of 'Runtime Timeout (millisecond)' Preference ? (Window > Preferences > Stambia > Runtime)
2. When you execute the process, does the error occurs immediately ? or after some time ? (how many time?)
3. Can you check if the process is executed even if this error occur ?

Please Log in or Create an account to join the conversation.

More
08 Jul 2016 10:21 #3 by Josserand BRINON
1. Runtime Timeout = 60000 ms
2. No, it occures after a long time. I've tried this morning: 108 seconds
3. Yesterday: the process executed once despite the error, the second try finished as "dead".
Today: the process executed despite the error.

I'm waiting for the end of the process, and I'm going to try to increase the Runtime Timeout (120000 ms) and... let's see.

Please Log in or Create an account to join the conversation.

More
08 Jul 2016 10:46 - 08 Jul 2016 10:47 #4 by Josserand BRINON
I've increased the value to 120000 ms (120 seconds).
Result: the same error occures after 103 seconds.
And the process started after about 110 seconds (7 seconds after the error).

It seems that the modification of the Runtime timeout value didn't have any impact on the behaviour of the execution :dry:
Last edit: 08 Jul 2016 10:47 by Josserand BRINON.

Please Log in or Create an account to join the conversation.

More
08 Jul 2016 13:09 #5 by Cyril Dussud
It is a big process executing sub-processes if I understood well?

If possible, what you can try is to separate the sub-process into several processes and then call them in your parent process with execute delivery actions instead of sub-processes. Do you see the idea?
Like this the 'sub-processes' will be executed separately in their own sessions instead of everything in one. It can help to decrease the weight of the main process.

Additionally, can you show the full stack trace of the error please?

Please Log in or Create an account to join the conversation.

More
08 Jul 2016 15:43 #6 by Josserand BRINON
Yes it is a process executing a lot of sub-processes.
I understand your idea. Actualy it is not ideal in our context, but still possible. I keep that in mind if we cannot find a solution.

I am a bit embarassed because I want to send you the full stack... and now it works continuously, three times... :unsure:
(FYI, I have decreased the Runtime Timeout value to the initial one (60000 ms).)

I keep you up to date as soon as it will stop working again... :oops:

Please Log in or Create an account to join the conversation.

More
12 Jul 2016 14:53 #7 by Josserand BRINON
Ok, the error has came back.
The full stack trace of the error is in the attached text file.

This message has an attachment file.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

More
13 Jul 2016 10:02 #8 by Cyril Dussud
Hi, this request will now be managed through the support because we need more precise information.
We sent you a message from the support ticket corresponding to this problem, please respond now on it.

We'll come back to the forum to post the solution after investigating with you.

Please Log in or Create an account to join the conversation.

More
25 Oct 2016 15:16 #9 by Cyril Dussud
Hi,

For history, we created an article that demonstrates how to change the timeout for the communication between the Designer and the Runtime:
stambia.org/kb/16-execution-issues/277-e...ng-a-process-mapping

This solution fixed the problem.

Please Log in or Create an account to join the conversation.