Welcome Guest! Log in
The Stambia User Community is moving to Semarchy! All the applicable resources have already been moved or are currently being moved to their new location. Read more…


Symptom

When you try to start the Stambia Designer and the following error is thrown:

java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: 
    /home/ennaji/Téléchargements/stambiaDesigner_S19.0.15_20190125_092334/stambia/configuration/org.eclipse.osgi/bundles/358/1/.cp/libswt-pi-gtk-4234.so: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
    no swt-pi-gtk in java.library.path
    Can't load library: /root/.swt/lib/linux/x86_64/libswt-pi-gtk-4234.so
    Can't load library: /root/.swt/lib/linux/x86_64/libswt-pi-gtk.so
    /root/.swt/lib/linux/x86_64/libswt-pi-gtk-4234.so: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:331)
    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:240)
    at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:22)
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
    at org.eclipse.swt.widgets.Display.<clinit>(Display.java:133)
    at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:653)
    at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
    at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:154)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:96)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

Solution

GTK is a multi-platform toolkit for creating graphical user interfaces.

The error indicates that libgtk-x11-2.0.so.0 cannot be found. Please make sure that you have GTK libraries installed on your machine.

For example, in Ubuntu you can find a package providing libgtk-x11-2.0.so.0 with the apt-file command:

 
  > apt-file find libgtk-x11-2.0.so.0
libgtk2.0-0: /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
 
If the GTK libraries can't be found, please use this command:
 

sudo apt-get install libgtk2.0-dev

Knowledge Base

Suggest a new Article!